杭电 2015 年计算机复试真题

写在前面

此题目是根据 CSDN 博客粥粥同学发布的内容进行收集整理,记录了本人的解题过程和一些想法。仅供大家参考,如有错误,欢迎大家指出!


第一题

Problem Description

给定一个字符串,计算字符串中数值的个数并求和。其中还包含了负号,若紧跟负号的是一个数值,则表示这是一个负数,若后面跟着的不是数字,则不表示什么。

Input

输入一个字符串,每个测试实例占一行

Output

输出首先是一个整数表示数字的个数,然后是数值之和,中间有空格,每个输出占一行

Sample Input

d10sdw-5cd
312ab-2—9–a

Sample Output

2 5
3 301

解题思路

遍历字符串,若为数字,则遍历这个数字后面的字符,直到不是数字位置,再更新位置;若为’-',则判断之后一个字符是否为数字,若是,则进行与前一种情况类似的操作

参考源码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
#include <cstring>
#include <iostream>
#include <vector>
using namespace std;
int main() {
int i, j, c, sum, temp;
string s;
while (cin >> s) {
c = sum = 0;
for (i = 0; i < s.length(); i++) {
if (isdigit(s[i])) {
temp = 0;
for (j = 0; isdigit(s[i + j]); j++) {
temp = temp * 10 + (s[i + j] - '0'); //拼接
}
i = i + j - 1; //更新
sum += temp;
c++;
} else if (s[i] == '-' && isdigit(s[i + 1])) {
temp = 0;
for (j = 1; isdigit(s[i + j]); j++) {
temp = temp * 10 + (s[i + j] - '0');
}
i = i + j - 1;
sum -= temp;
c++;
}
}
cout << c << " " << sum << endl;
}
return 0;
}

第二题

Problem Description

给定一个数字矩阵,如果上下左右数值相同,则表示是一个连通的区域。求矩阵中连通块的数量

Input

第一行先是矩阵的行数 n 和列数 m,接着是 n 行 m 列的矩阵

Output

输出连通块的数量

Sample Input

5 6
4 4 4 4 4 4
4 2 3 3 1 4
4 2 2 3 1 4
4 2 3 3 1 4
4 4 4 4 4 4

Sample Output

4

解题思路

使用深度优先的方法,遍历所有顶点,判断当前顶点周围的四个点是否与当前顶点的值相同

参考源码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include <iostream>
using namespace std;
int n, m;
int X[4] = {0, 0, 1, -1};
int Y[4] = {1, -1, 0, 0};
int map[1000][1000];
bool vis[1000][1000] = {false};

bool judge(int a, int b) {
if (a > n || b > m || a < 0 || b < 0) return false; //越界
return true;
}
int DFS(int x, int y) {
if (!judge(x, y)) return 0; //越界
vis[x][y] = true; //标记为访问
for (int i = 0; i < 4; i++) {
int newx = x + X[i];
int newy = y + Y[i];
if (!vis[newx][newy] && map[x][y] == map[newx][newy]) DFS(newx, newy);
}
return 0;
}
int main() {
int ans;
while (cin >> n >> m) {
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
cin >> map[i][j];
}
}
ans = 0;
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
if (!vis[i][j]) {
ans++;
DFS(i, j);
}
}
}
cout << ans << endl;
}
return 0;
}

相关内容